E30 M20 C191 Plug Replacement

The C191 plug connects the fuel injector harness to the rest of the electrical system. A bad C191 plug can lead to all sorts of problems –

  • hard starting
  • rough idle
  • lack of power
  • fault codes for fuel injectors or temp sensor

The location of the C191 plug makes it susceptible to water. Check out the corrosion on my plugs:

The connectors are not available separately from BMW. You have to buy a new fuel injector harness or engine harness. But why replace one defect with another? So that’s why a lot of E30 fixers have went aftermarket. I chose a motorsport/military spec Deutsch DT connector. I really should have read up on this during my engine build and it would have saved a lot of headache later on.

Do not hardwire the harnesses together. Although it may be tempting as an easy fix, there are major drawbacks to it. They should be separated so the harness can be removed during manifold or cylinder head service.

Replacing the connectors means cutting them off, exposing the wires, crimping pins to the ends, and inserting them into the Deutsch connector. There’s no easy way to do this with the harness on the car but removing it is very difficult too (and is only half of the harness).

The Deutsch connector is not for the weak. First, the connector set that I ordered from Amazon came with no instructions or diagram (no surprise). Videos and online descriptions were no help. The pins crimp differently than the usual crimp connectors. My multipurpose crimp tool did not work well and I settled for ordinary needle-nose pliers. Access and room to work is terrible. Once the wires are crimped they have to be pushed through the rubber seal and then locked down in the connector.

Here’s where a diagram would have come in handy: I didn’t know which pin went where. I wrongly assumed the male pins went in the male connector. After getting all 12 pins in place I realized it was the other way around and the pins weren’t making contact inside. Doh! Live and learn.

The male pins fit in the larger female housing and get locked in with the green wedgelock. The female receptacles fit in the male connector and should be flush with the housing (or just below the surface of the orange wedgelock once installed). I had to carefully pull them all out and run them through the opposite connector. Once that was done, probing with my volt meter confirmed the injector power line had 12.5v with the key on. I also probed the pin on the DME connector and the coolant temp sensor and both had the same resistance. So my little wiring project should be a success!

So why are the injectors not spraying and the engine still not starting?

To read more on this situation, see my M20 starter post by clicking here.

Click here for my C191 connector photos.

Advertisements
E30 M20 C191 Plug Replacement

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s